File Index
Files and directories
Sign in
FILE

msg_prot.h

File preview with syntax highlighting.

linux-6.19.14/include/linux/sunrpc/msg_prot.h C
  1/* SPDX-License-Identifier: GPL-2.0 */
  2/*
  3 * linux/include/linux/sunrpc/msg_prot.h
  4 *
  5 * Copyright (C) 1996, Olaf Kirch <okir@monad.swb.de>
  6 */
  7
  8#ifndef _LINUX_SUNRPC_MSGPROT_H_
  9#define _LINUX_SUNRPC_MSGPROT_H_
 10
 11#define RPC_VERSION 2
 12
 13/* spec defines authentication flavor as an unsigned 32 bit integer */
 14typedef u32	rpc_authflavor_t;
 15
 16enum rpc_auth_flavors {
 17	RPC_AUTH_NULL  = 0,
 18	RPC_AUTH_UNIX  = 1,
 19	RPC_AUTH_SHORT = 2,
 20	RPC_AUTH_DES   = 3,
 21	RPC_AUTH_KRB   = 4,
 22	RPC_AUTH_GSS   = 6,
 23	RPC_AUTH_TLS   = 7,
 24	RPC_AUTH_MAXFLAVOR = 8,
 25	/* pseudoflavors: */
 26	RPC_AUTH_GSS_KRB5  = 390003,
 27	RPC_AUTH_GSS_KRB5I = 390004,
 28	RPC_AUTH_GSS_KRB5P = 390005,
 29	RPC_AUTH_GSS_LKEY  = 390006,
 30	RPC_AUTH_GSS_LKEYI = 390007,
 31	RPC_AUTH_GSS_LKEYP = 390008,
 32	RPC_AUTH_GSS_SPKM  = 390009,
 33	RPC_AUTH_GSS_SPKMI = 390010,
 34	RPC_AUTH_GSS_SPKMP = 390011,
 35};
 36
 37/* Maximum size (in octets) of the machinename in an AUTH_UNIX
 38 * credential (per RFC 5531 Appendix A)
 39 */
 40#define RPC_MAX_MACHINENAME	(255)
 41
 42/* Maximum size (in bytes) of an rpc credential or verifier */
 43#define RPC_MAX_AUTH_SIZE (400)
 44
 45enum rpc_msg_type {
 46	RPC_CALL = 0,
 47	RPC_REPLY = 1
 48};
 49
 50enum rpc_reply_stat {
 51	RPC_MSG_ACCEPTED = 0,
 52	RPC_MSG_DENIED = 1
 53};
 54
 55enum rpc_accept_stat {
 56	RPC_SUCCESS = 0,
 57	RPC_PROG_UNAVAIL = 1,
 58	RPC_PROG_MISMATCH = 2,
 59	RPC_PROC_UNAVAIL = 3,
 60	RPC_GARBAGE_ARGS = 4,
 61	RPC_SYSTEM_ERR = 5,
 62	/* internal use only */
 63	RPC_DROP_REPLY = 60000,
 64};
 65
 66enum rpc_reject_stat {
 67	RPC_MISMATCH = 0,
 68	RPC_AUTH_ERROR = 1
 69};
 70
 71enum rpc_auth_stat {
 72	RPC_AUTH_OK = 0,		/* success */
 73	RPC_AUTH_BADCRED = 1,		/* bad credential (seal broken) */
 74	RPC_AUTH_REJECTEDCRED = 2,	/* client must begin new session */
 75	RPC_AUTH_BADVERF = 3,		/* bad verifier (seal broken) */
 76	RPC_AUTH_REJECTEDVERF = 4,	/* verifier expired or replayed */
 77	RPC_AUTH_TOOWEAK = 5,		/* rejected for security reasons */
 78	RPC_AUTH_INVALIDRESP = 6,	/* bogus response verifier */
 79	RPC_AUTH_FAILED = 7,		/* reason unknown */
 80	/* RPCSEC_GSS errors */
 81	RPCSEC_GSS_CREDPROBLEM = 13,	/* no credentials for user */
 82	RPCSEC_GSS_CTXPROBLEM = 14	/* problem with context */
 83};
 84
 85#define RPC_MAXNETNAMELEN	256
 86
 87/*
 88 * From RFC 1831:
 89 *
 90 * "A record is composed of one or more record fragments.  A record
 91 *  fragment is a four-byte header followed by 0 to (2**31) - 1 bytes of
 92 *  fragment data.  The bytes encode an unsigned binary number; as with
 93 *  XDR integers, the byte order is from highest to lowest.  The number
 94 *  encodes two values -- a boolean which indicates whether the fragment
 95 *  is the last fragment of the record (bit value 1 implies the fragment
 96 *  is the last fragment) and a 31-bit unsigned binary value which is the
 97 *  length in bytes of the fragment's data.  The boolean value is the
 98 *  highest-order bit of the header; the length is the 31 low-order bits.
 99 *  (Note that this record specification is NOT in XDR standard form!)"
100 *
101 * The Linux RPC client always sends its requests in a single record
102 * fragment, limiting the maximum payload size for stream transports to
103 * 2GB.
104 */
105
106typedef __be32	rpc_fraghdr;
107
108#define	RPC_LAST_STREAM_FRAGMENT	(1U << 31)
109#define	RPC_FRAGMENT_SIZE_MASK		(~RPC_LAST_STREAM_FRAGMENT)
110#define	RPC_MAX_FRAGMENT_SIZE		((1U << 31) - 1)
111
112/*
113 * RPC call and reply header size as number of 32bit words (verifier
114 * size computed separately, see below)
115 */
116#define RPC_CALLHDRSIZE		(6)
117#define RPC_REPHDRSIZE		(4)
118
119
120/*
121 * Maximum RPC header size, including authentication,
122 * as number of 32bit words (see RFCs 1831, 1832).
123 *
124 *	xid			    1 xdr unit = 4 bytes
125 *	mtype			    1
126 *	rpc_version		    1
127 *	program			    1
128 *	prog_version		    1
129 *	procedure		    1
130 *	cred {
131 *	    flavor		    1
132 *	    length		    1
133 *	    body<RPC_MAX_AUTH_SIZE> 100 xdr units = 400 bytes
134 *	}
135 *	verf {
136 *	    flavor		    1
137 *	    length		    1
138 *	    body<RPC_MAX_AUTH_SIZE> 100 xdr units = 400 bytes
139 *	}
140 *	TOTAL			    210 xdr units = 840 bytes
141 */
142#define RPC_MAX_HEADER_WITH_AUTH \
143	(RPC_CALLHDRSIZE + 2*(2+RPC_MAX_AUTH_SIZE/4))
144
145#define RPC_MAX_REPHEADER_WITH_AUTH \
146	(RPC_REPHDRSIZE + (2 + RPC_MAX_AUTH_SIZE/4))
147
148/*
149 * Well-known netids. See:
150 *
151 *   https://www.iana.org/assignments/rpc-netids/rpc-netids.xhtml
152 */
153#define RPCBIND_NETID_UDP	"udp"
154#define RPCBIND_NETID_TCP	"tcp"
155#define RPCBIND_NETID_RDMA	"rdma"
156#define RPCBIND_NETID_SCTP	"sctp"
157#define RPCBIND_NETID_UDP6	"udp6"
158#define RPCBIND_NETID_TCP6	"tcp6"
159#define RPCBIND_NETID_RDMA6	"rdma6"
160#define RPCBIND_NETID_SCTP6	"sctp6"
161#define RPCBIND_NETID_LOCAL	"local"
162
163/*
164 * Note that RFC 1833 does not put any size restrictions on the
165 * netid string, but all currently defined netid's fit in 5 bytes.
166 */
167#define RPCBIND_MAXNETIDLEN	(5u)
168
169/*
170 * Universal addresses are introduced in RFC 1833 and further spelled
171 * out in RFC 3530.  RPCBIND_MAXUADDRLEN defines a maximum byte length
172 * of a universal address for use in allocating buffers and character
173 * arrays.
174 *
175 * Quoting RFC 3530, section 2.2:
176 *
177 * For TCP over IPv4 and for UDP over IPv4, the format of r_addr is the
178 * US-ASCII string:
179 *
180 *	h1.h2.h3.h4.p1.p2
181 *
182 * The prefix, "h1.h2.h3.h4", is the standard textual form for
183 * representing an IPv4 address, which is always four octets long.
184 * Assuming big-endian ordering, h1, h2, h3, and h4, are respectively,
185 * the first through fourth octets each converted to ASCII-decimal.
186 * Assuming big-endian ordering, p1 and p2 are, respectively, the first
187 * and second octets each converted to ASCII-decimal.  For example, if a
188 * host, in big-endian order, has an address of 0x0A010307 and there is
189 * a service listening on, in big endian order, port 0x020F (decimal
190 * 527), then the complete universal address is "10.1.3.7.2.15".
191 *
192 * ...
193 *
194 * For TCP over IPv6 and for UDP over IPv6, the format of r_addr is the
195 * US-ASCII string:
196 *
197 *	x1:x2:x3:x4:x5:x6:x7:x8.p1.p2
198 *
199 * The suffix "p1.p2" is the service port, and is computed the same way
200 * as with universal addresses for TCP and UDP over IPv4.  The prefix,
201 * "x1:x2:x3:x4:x5:x6:x7:x8", is the standard textual form for
202 * representing an IPv6 address as defined in Section 2.2 of [RFC2373].
203 * Additionally, the two alternative forms specified in Section 2.2 of
204 * [RFC2373] are also acceptable.
205 */
206
207#include <linux/inet.h>
208
209/* Maximum size of the port number part of a universal address */
210#define RPCBIND_MAXUADDRPLEN	sizeof(".255.255")
211
212/* Maximum size of an IPv4 universal address */
213#define RPCBIND_MAXUADDR4LEN	\
214		(INET_ADDRSTRLEN + RPCBIND_MAXUADDRPLEN)
215
216/* Maximum size of an IPv6 universal address */
217#define RPCBIND_MAXUADDR6LEN	\
218		(INET6_ADDRSTRLEN + RPCBIND_MAXUADDRPLEN)
219
220/* Assume INET6_ADDRSTRLEN will always be larger than INET_ADDRSTRLEN... */
221#define RPCBIND_MAXUADDRLEN	RPCBIND_MAXUADDR6LEN
222
223#endif /* _LINUX_SUNRPC_MSGPROT_H_ */
~/ Read-only file preview.